Методическое пособие по изучению microsoft




Скачать 18.98 Kb.
НазваниеМетодическое пособие по изучению microsoft
страница4/12
Дата03.02.2016
Размер18.98 Kb.
ТипМетодическое пособие
1   2   3   4   5   6   7   8   9   ...   12

6.4.10.Создание запроса на добавление


С помощью Запроса на добавление производится добавление записей из таблицы с результатами запроса в таблицу базы данных. Поэтому в запросе должны быть сформированные записи с полями, соответствующими полями в дополняемой записями таблице базы данных.

Пусть в некотором подразделении создается таблица об успеваемости студентов УСПВРЕМ и необходимо её данными дополнять таблицу УСПЕВАЕМОСТЬ, сохраняемую в централизованной базе данных. Сделайте копию таблицы УСПЕВАЕМОСТЬ и переименуйте её в таблицу УСПВРЕМ. Измените данные полученной таблицы в соответствии с Таблицей 4.1.

Таблица 6.4.1.

Данные таблицы УСПВРЕМ.

Номер группы

Ном.студента

Код предм.

Табл. номер преподавателя

Вид занятий

ОЦЕНКА

101

04

01

103

лек.

5

102

01

03

203

пр.

5

102

03

01

103

пр.

3

103

01

02

204

пр.

4

103

01

03

502

пр.

5

201

01

04

103

лек.

4

202

01

04

601

пр.

4

203

01

04

602

пр.

2




  1. Первоначально создайте в режиме конструктора Запрос на выборку на основе таблицы УСПВРЕМ, перетаскивая в бланк запроса все поля таблицы.

  2. Затем в окне конструктора запросов превратите его в Запрос на добавление, выбрав тип запроса Добавление или команду меню Запрос|Добавление. При этом открывается диалоговое окно Добавление.

  3. В этом окне в поле имя таблицы введите или выберите из списка имя таблицы УСПЕВАЕМОСТЬ, в которую надо добавит записи.

  4. Если таблица УСПВРЕМ размещена в одной открытой базе данных с таблицей- приёмником добавляемых записей, отметьте в текущей базе данных. Для таблицы, находящейся в другой базе данных, надо отметить в другой базе данных и ввести имя файла базы данных. При необходимости надо указать путь.

  5. После преобразования запроса в запрос на добавление в бланке появляется строка Добавление (рис. 6.4.9.).

  6. Поскольку в данном примере имена полей обеих таблиц совпадают, Access автоматически сформирует в строке Добавление имена полей таблицы – получателя, соответствующих полям таблицы запроса, откройте в каждой ячейки список полей и выберите нужное имя.

  7. Для добавление записей нажмите кнопку Запуск на панели инструментов.

  8. Для просмотра выполненного запроса откройте таблицу УСПЕВАЕМОСТЬ в режиме таблицы. В результате были добавлены 8 записей в таблицу УСПЕВАЕМОСТЬ.




Рис. 6.4.9. Пример бланка запроса на добавление

Удаление записей


Запрос на удаление позволяет удалить записи из одной таблицы или из нескольких взаимосвязанных таблиц, для которых не установлен параметр обеспечение целостности данных. В запросе указывается таблица, из которой должны удалятся записи, и задаются условия отбора удаляемых записей.

Упражнение 6.4.11.Создание запроса на удаление

Рассмотрим формирования запроса на удаление записи о студенте группы 204 Петрове В.М. 1999 года рождения из таблицы СТУДЕНТ. Но сначала надо ввести эту дополнительную запись в таблицу СТУДЕНТ.

  1. Сначала создайте Запрос на выборку, в схему данных которого включите таблицу СТУДЕНТ.

  2. Теперь приступите к формированию бланка запроса. Переместите символ звездочки (*) из списка полей таблицы СТУДЕНТ в бланк запроса. Перетащите поле ГОДР в бланк запроса.

  3. Затем в режиме конструктора преобразуйте запрос в Запрос на удаление, выбрав на панели инструментов тип запроса Удаление или выполнив команду меню Запрос|Удаление. После преобразования запроса в запрос на удаление в бланке появится строка Удаление. В строке Удаление в столбце Студент.* появляется значение Из, а в столбце ГОДР- Условие.

  4. Чтобы создать условие отбора удаляемой записи, заполните строку Условие отбора выражением: [год рождения].

  5. Сохраните запрос под именем Запрос на удаление студента.

  6. Откройте этот запрос введите в диалоговое окно год 1999 и нажмите ОК.

  7. Проверьте изменения в таблице СТУДЕНТ.


Перекрестные запросы.

Перекрестный запрос является специальным запросом итогового типа. Такой запрос позволяет увидеть вычисляемые значения в виде перекрестной таблицы, напоминающей электронную таблицу.

Упражнение 6.4.12. Создание перекрестной таблицы


Рассмотрим создание перекрестной таблицы на примере таблицы УСПЕВАЕМОСТЬ. Пусть необходимо для каждого преподавателя определить число студентов, знания которых по лекционному или практическому занятию он оценил.

  1. Для создания запроса в окне базы данных выберите объект Запросы и нажмите кнопку Создать.

  2. В окне Новый запрос выберите Перекрестный запрос.

  3. В окне мастера Создания перекрестных таблиц выберите таблицу УСПЕВАЕМОСТЬ, поля которой будут выведены в перекрестном запросе.

  4. В следующем окне мастера выберите для заголовков строк поле ТАБН – табельный номер преподавателя. Для выбора используйте кнопку >.

  5. Для заголовка столбцов выберите ВИДЗ (Вид занятий).

  6. Для подсчета числа студентов, которые экзаменовались у данного преподавателя по данному виду занятия, и размещения этого значения в ячейке на пересечении строк и столбцов таблицы выберите поле НС (Номер студента) и функцию Число.

  7. Чтобы подсчитать общее количество студентов, значения которых оценивал преподаватель, в этом же окне установите флажок Вычислить итоговое значение для каждой строки?

8. Задайте имя запроса Число сдач и нажмите кнопку Готово.

6.4.13.Создание перекрестной таблицы в режиме конструктора.

В этом упражнении рассмотрим, как создать перекрестную таблицу на основе одной таблицы ИЗУЧЕНИЕ, в которой заголовками строк будут табельный номер преподавателя (ТАБН), столбцы – коды предмета (КП), а на пересечении строк и столбцов – сумма часов по полю ЧАСЫ.

  1. Начните построение запроса как обычно, например, двойным щелчком мыши на строке Создание запроса в режиме конструктора в окне базы данных.

  2. В окне Добавления таблицы включите в схему данных запроса таблицу ИЗУЧЕНИЕ, содержащую все необходимые поля.

  3. В бланк запроса перетащите поля ТАБН, КП, по которым будет осуществляться группировка, и которые будут использоваться в строках и столбцах перекрестной таблицы соответственно, и поле ЧАСЫ, по которому будет подсчитываться суммарное число часов для полученных групп.

  4. В окне конструктора преобразуйте запрос на выборку в перекрестный запрос. Для этого выберите тип запроса Перекрестный на панели инструментов или выполните команду меню Запрос|Перекрестный. В бланке запроса появится две дополнительные строки Групповая операция и Перекрестная таблица.

  5. В строке Перекрестная таблица для поля ТАБН выберите из списка значение Заголовки строк, для поля КП – Заголовки столбцов, для поля ЧАСЫ – Значение.

  6. В строке Групповая операция для поля ЧАСЫ выберите из списка значение Sum, оставив в остальных строках значение Группировка.

  7. Для включения в перекрестную таблицу итоговых значений для каждой строки дополните бланк запроса ещё одним полем ЧАСЫ, замените значение Группировка на Sum, а в строке Перекрестная таблица выберите Заголовки строк.

  8. Сохраните запрос под именем Часы преподавателей и выполните его.

Для информативности полученной перекрестной таблицы замените в ней табельные номера фамилиями преподавателей, а коды предметов их наименованиями. Полю содержащему результат суммирования по стрелкам, дайте пользовательское имя Всего часов.

  1. Вернитесь в режим конструктора запроса Часы преподавателей.

  2. Поле с фамилией преподавателя размещено в таблице ПРЕПОДАВАТЕЛЬ, а с наименованием предмета НП в таблице ПРЕДМЕТ, поэтому добавьте в схему запроса эти таблицы.

  3. Замените в бланке запроса поле КП на поле НП таблицы ПРЕДМЕТ, а поле ТАБН на поле ФИО таблицы ПРЕПОДАВАТЕЛЬ. Для этого в поле КП в строке Имя таблицы нажмите кнопку списка и выберите ПРЕДМЕТ, а в строке Поле – НП. Аналогичными действиями замените ТАБН на ФИО.

  4. Для изменения подписи поля, содержащего итоговую сумму по строкам, щелкните правой кнопкой мыши в зоне этого поля. В открывшемся контекстно-зависимом меню выберите пункт Свойства. В окне Свойства поля введите Всего часов в строку Подпись поля. Можно ввести эти подписи непосредственно в поле перед именем ЧАСЫ, отделив подпись от именем двоеточием.

  5. Сохраните и выполните запрос.

Задания для самостоятельной работы:

Выполните запрос с функцией Avg. Подсчитайте средний проходной балл в группе.

Контрольные вопросы

  1. Какая команд меню позволяет добавить необходимые таблицы в запрос?

  2. Как в запросе отобразить нужные поля в таблицы?

  3. Как выполнить запрос не открывая его в режиме конструктора?

  4. Мешает ли объединению установка флажка Обеспечение целостности данных?

  5. В каком окне какой кнопкой открывается возможность выбора параметра объединения?

  6. Изменится ли параметр объединения таблиц, установленный в запросе, если изменить его в схеме данных?

  7. Можно ли запросы – действия создать с помощью мастера?

  8. Какой командой осуществляется преобразование запроса на выборку в запрос на добавление?

  9. Сколько таблиц использует мастер при построении перекрестного запроса?

6.5. Лабораторная работа №5

Разработка форм

Цель лабораторной работы: научиться создавать однотабличные формы в режиме автоформы, включать в формы связанные поля базового источника, создавать поле при использовании элемента Свободный, создавать двухтаблицные формы, создавать кнопочную форму, редактировать формы в режиме конструктора, подсчитывать итоговые значения в форме.

Формы являются основной разработки диалоговых предложений. Через формы можно загружать данные во взаимосвязанные таблицы базы данных с документов- источников, просматривать данные, а также их корректировать. Работая с формой, пользователь может добавлять и удалять записи в таблицах, изменять значения в полях, получать расчетные данные. В форме можно контролировать вводимые данные, Устанавливать ограничения на доступ к данным, выводить необходимые сообщения.

При работе с формами может выполнятся обработка событий, инициируемых пользователем или наступающих в процессе работы с формой. Форма может создаваться для управления приложением пользователя. Типовые процедуры формируются автоматически при создании элементов формы. Такими элементами, например, являются, графические кнопки, с которыми могут связываться события следующих категорий: переход по записям, обработка записей; работа с формой; работа с отчетом; запуск запроса, макроса, печать таблицы, набор номера

Упражнение 6.5.1.Создание однотабличной формы в режиме автоформы.

Рассмотрим создание однотабличной формы на примере таблицы ПРЕДМЕТ базы данных Учебный процесс. Режим Автоформы обеспечить ввод/вывод всех полей выбранной таблицы.

  1. В окне базы данных Учебный процесс: база данных в области Объекты выберите Формы и нажмите кнопку Создать.

  2. В окне Новая форма выберите в качестве источника данных таблицу ПРЕДМЕТ и режим создания - Автоформа: в столбец. Работа команды Автоформа: в столбец завершается отображением формы (рис. 6.5.1.).



Рис.6.5.1.Результат работы команды Автоформа: в столбец.


Упражнение 6.5.2. Конструирование новой формы и включение в нее связанных полей базового источника

  1. Выберем в окне Учебный процесс: база данных объекты Форма и нажмите кнопку Создать, которая вызывает окно Новая форма.

  2. Выберите в окне Новая форма режим Конструктор. В качестве базового источника данных формы можно открыть список и выделить таблицу КАФЕДРА. После вызова конструктора форм появится окно конструктора с именем формы по умолчаниюФорма1.

  3. Для включения в форму полей, связанных с базовым источником записей КАФЕДРА, отобразим на экране список полей этого источника. Для этого выполним команду меню Вид|Список полей или нажмите кнопку на панели конструктора форм.

  4. Из списка полей перетащим нужные поля в область данных формы с помощью мыши. При отпускании кнопки мыши размещается поле и связанная с ним подпись. В самом поле будет отображено имя поля таблицы базы данных, а в качестве надписи будет использовано значение из свойства поля Подпись, которое было определено при конструировании таблицы (рис.6.5.2.).



Рис.6.5.2. Результат формы КАФЕДРА в режиме конструктора.

  1. Сохраните форму под именем КАФЕДРА.

Упражнение 6.5.3. Создание поля при использовании элемента Свободный.

Создание в форме поля может быть выполнено с помощью кнопок панели элементов Поле типа Свободный.

  1. Для включения поля нажмите на панели элементов кнопку Поле и вычертив курсором поле в нужном месте формы.

  2. Для установки связи создаваемого поля формы с полем таблицы КАФЕДРА – источника записей формы – выделим создаваемое поле в форме и вызовем окно его свойств. В этом окне на вкладке Данные в строке Данные выберем нужное поле из списка доступных полей источника и закроем окно свойств.

Создание взаимосвязанных таблиц

Упражнение 6.5.4. Создание с помощью мастера двухтабличной формы с включением подчиненной формы

Осуществим средствами Access конструирование формы для одновременной работы с таблицами ГРУППА и СТУДЕНТ в базе данных Учебный процесс.

  1. Перейдем в режим создания формы. Для этого в окне Учебный процесс: база данных выбираем в области Объекты строку Формы и нажимаем кнопку Создать.

  2. В диалоговом окне Новая форма выбираем режим создания Мастера форм и таблицу ГРУППА, которая будет служить источником записей для основной части создаваемой многотабличной формы.

В открывшемся окне Создание формы в списке Таблицы и Запросы сначала будет отражена ранее выбранная таблица ГРУППА и ее поля.

  1. Выберем для таблицы ГРУППА в списке Доступные поля: НГ, КОЛ, ПБалл, перемещая их в область Выбранные поля.

  2. Выберем далее из списка Таблицы и Запросы таблицу СТУДЕНТ и в списке Доступные поля этой таблицы аналогично предыдущему пункту: НС, ФИО, ГОДР, Пбалл. Эта таблица будет источником записей формы, связанных с записью, отображаемой в основной части формы. Нажмите кнопку Далее>.

В новом сеансе окна Создания формы схематично отобразится макет формы с перечнем полей в основной части формы и в подчиненной форме, если в рамке. Выберите вид представления данных выведена таблицаисточник записей основной части формы (ГРУППА).

  1. Для непосредственного включения подчиненной формы выберем вариант Подчиненная форма.

  2. В следующем диалоговом окне мастера для получения многозаписевой подчиненной формы и вывода подписей полей (определенных в свойствах таблиц) выберем внешний вид подчиненной формы – ленточный.

  3. После нажатия кнопки Далее> в очередном сеансе диалогового окна выберем стиль оформления. Например, если выбрать Стандартный, получим форму с утопленными полями.

  4. В последнем окне Создания форм введем имена (заголовки) составной формы ГРУППЫ и подчиненной формы СПИСОК СТУДЕНТОВ.

  5. Выберем в этом же окне дальнейшие действия мастера – Открытие формы для просмотра и ввода данных. Это позволит после завершения работы мастера сразу приступить к работе с данными через форму.

  6. Нажмите кнопку Готово для того, чтобы мастер завершил создание формы мастером. Сохранение формы производится автоматически.

Соответственно выбранным действиям мастер выводит форму с данными из таблиц ГРУППА и СТУДЕНТ. При этом в основной части формы отображаются данные одной текущей записи таблицы ГРУППА. В подчиненной форме выводятся те записи таблицы СТУДЕНТ, которые связанны с текущей таблицей ГРУППА.

Редактирование созданной формы

Ранее созданная форма может быть отредактирована в режиме конструктора форм. Создавая форму с помощью мастера, можно перейти к доработке формы в последнем сеансе окне Создание форм, выбрав дальнейшие действия – Изменить макет форм. Тогда форма выводится в режиме конструктора, позволяющем произвести желаемую доработку. После работы мастера в макете форм будут размещены заданные поля из таблиц – источников основной и подчиненных форм.

В процессе доработке формы, используя технику редактирования формы, можно перемещать поля в основной и подчиненной форме, менять их свойства, в том числе шрифт и размеры, подпись поля, текст в заголовке формы, а также добавлять поля в форму. Если курсор установлен на основной или подчиненной форме, то при нажатии кнопке Список полей панели конструктора форм становится доступным список полей таблицы – источника соответствующей формы, которые можно добавить.

Упражнение 6.5.5. Изменение надписей и размещение полей

Откроем форму ГРУППЫ в режиме конструктора. Здесь предоставлены поля, размещенные в области данных, с надписями основной части формы, а также поля и надписи подчиненной формы СПИСОК СТУДЕНТОВ внутри рамки, созданной для нее мастером.

Произведем следующие действия по доработке формы ГРУППЫ.

  1. Введем в область заголовка формы полное название формы СПИСОК СТУДЕНТОВ ГРУППЫ №:, которое будет выводится при распечатке формы. Уточним подписи полей, шрифт и размеры полей и подписей, заголовок формы. Для изменения размера любого элемента надо расширить или сжимать рамочку в соответствии с размером и шрифтом текста.

  2. Скопируйте надпись НГ в Заголовок формы, удалив при этом её из Области данных. Результат полученной формы ГРУППЫ в режиме конструктора изображен на рис.6.5.3.

Рис 6.5.3. Форма для двух таблиц ГРУППА и СТУДЕНТ в режиме конструктора

Упражнение 6.5.6. Создание кнопок управления с помощью мастера

Для того чтобы в форме переходить к следующей и предыдущей записи таблицы ГРУППА, создадим соответствующие кнопки управления в основной части формы ГРУППЫ.

  1. Начнем формирование элемента управления Кнопка в заданном месте формы. Нажмем кнопку Мастер элементов на панели элементов, а затем используем инструмент Кнопка. После нажатия, переноса кнопки курсором мыши в область заголовки формы и вычерчивания ее рамки запустится мастер кнопок Создание кнопок.

  2. В окне мастера кнопок выберем действие, которое необходимо выполнять при нажатии кнопки. В области Категории выберем Переходы по записям, в области Действия выберем Предыдущая запись.

  3. В следующем сеансе диалогового окна можно выбрать вид кнопки – Текст или Рисунок и выбрать его из списка. Отметим Рисунок и Показать все рисунки. Далее выбираем подходящий Рисунок из списка, например, Стрелка вверх (синяя).

  4. Нажмем Готово, в результате чего копка перехода с выбранным рисунком встраивается в формы.

  5. Аналогичные действия произведем для встраивания кнопки перехода к последующей записи таблицы, выбирая в области Действия соответственно пункт Следующая запись, и рисунок Стрелка вниз (синяя).

  6. Отредактируем размер и надписи кнопок для перехода к записи другой группы, записав ПРЕДЫДУЩАЯ, СЛЕДУЮЩАЯ.

  7. Для создание кнопки закрытия формы в области Категории выбираем Работа с формой, а в области Действия выбираем Закрыть форму.

На рис.6.5.4. показана окончательна отредактированная основная часть формы с именем ГРУППЫ.

Рис. 6.5.4. Форма ввода-вывода для работы с данными двух взаимосвязанных таблиц.

Упражнение 6.5.7. Вычисление итогового значения для записей подчиненной формы и вывод его основной форме

Пусть в форме ГРУППЫ нужно на основе записей подчиненной формы СПИСОК СТУДЕНТОВ посчитать число студентов в каждой группе.

  1. Откройте форму СПИСОК СТУДЕНТОВ в режиме конструктора.

  2. В этой форме в области примечания создадим вычисляемый элемент управления с именем Количество студентов в группе и запишем туда выражение: =Count([ФИО]) (рис.6.5.5.).

  3. Откройте форму ГРУППЫ в режиме таблицы и убедитесь в работе вычисляемого элемента.





Рис. 6.5.5. Вычисление итогового значения в подчиненной форме.


Упражнение 6.5.8. Использование запроса в качестве источника записей многотабличной формы

Рассмотрим включение в новую форму при ее конструировании поля ФИО из таблицы ПРЕПОДАВАТЕЛЬ и поля НКАФ (название кафедры) из таблицы КАФНДРА.

  1. Выберем в окне Новая форма режим Конструктор.

  2. Откроем таблицу свойств новой формы и вызовем построитель на вкладке Данные нажатием кнопки , появляющейся при установке курсора за строкой Источник записей. Одновременно появляется окно построителя запросов и диалоговое окно Добавления таблицы.

  3. В окне Добавление таблицы выберем таблицу КАФЕДРА и ПРЕПОДАВАТЕЛЬ, которые отобразятся в схеме данных запроса.

  4. В бланк запроса перенесем поле ФИО из списка полей таблицы ПРЕПОДАВАТЕЛЬ и поле НКАФ из списка полей таблицы КАФЕДРА.

  5. Закроем окно построителя запроса, подтверждая необходимость сохранения сформировавшейся инструкции SQL.

  6. Отобразим доступные поля сформированного источника формы. Для этого можно выполнить команду Вид|Список полей или нажать кнопку Список полей на панели конструктора форм.

  7. Перетащите с помощью мыши поля из полученного списка в область данных формы.

  8. Сохраните форму под именем ПРЕПОДАВАТЕЛИ.

Кнопочная форма

Кнопочная форма выполняет роль панели управления приложением. Такая панель управления содержит кнопки, обеспечивающие вызов других кнопочных форм, а также отдельных объектов – отчетов, форм, макросов, модулей, с которых начинается решение задачи. Сюда же помещаются кнопки, предназначенные для возврата к кнопочным формам предыдущих уровней или вывода из Access. Обычно предусматривается кнопка для изменения самой кнопочной формы.

Упражнение 6.5.9.Создание двухуровневой структуры кнопочной формы с помощью диспетчера

Создадим кнопочную форму, которая будет использоваться как панель управления приложением Учебный процесс. Создадим главную и одну подчиненную кнопочную форму – КАФЕДРА.

  1. Выберем команду Сервис|Служебные программы|Диспетчер кнопочных форм.

  2. В окне Диспетчер кнопочных форм подтвердим создание кнопочной формы.

В окне Диспетчер кнопочных форм появится область со строкой Главная кнопочная форма (по умолчанию) (Switchboard Manager (Default)). В окне области диспетчера кнопочных форм формируется список кнопочных форм разных уровней.

  1. Для создание кнопочной формы в окне диспетчера кнопочных форм нажмем кнопку Создать.

  2. В окне Создание в поле Имя страницы кнопочной формы введем имя подчиненной кнопочной формы КАФЕДРА.

  3. Нажмем кнопку ОК, после чего в окне диспетчера кнопочных форм появится строка КАФЕДРА.

  4. Для формирования кнопок главной кнопочной формы в окне Диспетчер кнопочных форм выделим строку Switchboard Manager (Default) и нажмем кнопку Изменить.

  5. В окне диалога Изменение страницы кнопочной формы переименуем главную кнопочную форму в Учебный процесс, введя это имя в поле Название кнопочной формы.

  6. Для формирования в главной кнопочной форме Учебный процесс кнопки вызова подчиненной кнопочной формы КАФЕДРА нажмем кнопку Создать.

  7. В окне Изменения элемента кнопочной формы в раскрывающемся списке Команда выберем Переход к кнопочной форме.

  8. В раскрывающемся списке Кнопочная форма выберем форму КАФЕДРА.

  9. В поле текст введем подпись для этой кнопки Переход к кнопочной форме КАФЕДРА.

  10. Для завершения формирования элемента нажмем кнопку ОК. Элемент отобразится в списке Элементы данной кнопочной формы.

  11. Аналогичным путем создадим кнопку ПРЕПОДАВАТЕЛИ с командой Открыть форму для добавления, кнопку КАФЕДРЫ в подчиненной кнопочной форме с командой Открыть форму для изменения, и кнопку для перехода к главной кнопочной форме Учебный процесс.

  12. Для обеспечения перехода к редактированию созданных кнопочных форм создадим в главной кнопочной форме кнопку с именем Изменение кнопочной формы, выбрав для нее команду Конструктор приложения. В дальнейшем это позволит в любой момент вызвать Диспетчер кнопочных форм и с его помощью внести необходимые изменения.

  13. Для завершение работы с приложением создадим кнопку, выбрав для нее команду Выход из приложения, и присвоим ей имя Выход из приложения.

  14. Закончив создание страницы главной кнопочной формы, нажмем кнопку Закрыть. Это позволит вернуться к списку всех кнопочных форм приложения и снова нажмите кнопку Закрыть.

  15. В окне базы данных переименуйте эту форму в Кнопочную форму.

Таким образом можно установить все необходимые связи между кнопочными формами, представленными в списке окна диспетчера кнопочных форм. Практически на эти связи и число уровней не накладывается ограничений и могут быть созданы любые удобные пользователю переходы по кнопочным формам.

Задания для самостоятельной работы

Создайте форму где буду использоваться поля со списком. Например форма содержит две таблицы ПРЕПОДАВАТЕЛЬ И ПРЕДМЕТ поля одной из таблиц будут со списком.

Контрольные вопросы

  1. Может ли форма, созданная мастером, содержать данные из нескольких таблиц?

  2. Какая панель инструментов активизируется при открытии формы?

  3. Можно ли изменить вид кнопки после завершения работы мастером?

  4. Какой элемент управления позволяет создать вычисляемое поле?

  5. Как вызвать построитель для формирования выражения в вычисляемом поле?

  6. На основе каких объектов мастер может создать подчиненную форму?

6.6. Лабораторная работа № 6

Разработка отчетов

Цель лабораторной работы: научиться создавать однотабличный отчет с помощью мастера и включать в отчет вычисляемые поля, дату и номер страницы, а также научиться создавать в многотабличном отчете основную часть отчета и подчиненную, сконструировать отчет на основе запроса.

Средства разработки отчетов в Access предназначены для создания макета отчета, по которому может быть осуществлен вывод в виде выходного печатного документа. Эти средства позволяют создавать отчет сложной структуры, обеспечивающей вывод взаимосвязанных данных из многих таблиц, их группировку, вычисление итоговых данных.

Отчет может создаваться с помощью мастера или в режиме конструктора отчетов. Отчет созданный мастером, можно доработать в режиме конструктора.

Разделы отчета

При создании в режиме конструктора в окне первоначально отображаются пустые разделы отчета так как показано на рис.6.6.1.



Рис. 6.6.1. Разделы отчетов в режиме конструктора отчетов

При создании отчета его разделы нужно заполнить элементами в соответствии с макетом отчета, разработанным пользователем. В заголовок помещается текст с макетом отчета, разработанным пользователем. В заголовок помещается текст из шапки макета отчета. В верхней и нижний колонтитул обычно помещают заголовки, номера страниц и даты. При определении содержания этих разделов следует исходить из требований к оформлению отдельных страниц отчета. В области данных размещаются поля таблиц базы данных или запросов.

Если необходимо сгруппировать записи по полю, в окно конструктора отчетов могут быть добавлены разделы Заголовок группы и Примечание группы. В заголовке группы, как правило, размещаются поля, по которым производится группировка. В примечании группы могут быть размещены выражения для подведение итогов по группе. Допускается до 10 уровней группировки выводимых записей.

В процессе конструирования с помощью команд меню или кнопок панели инструментов конструктора отчетов и панели элементов заполняются разделы отчета теми элементами, которые соответствуют планируемому макету отчета.

Поля с неповторяющимися значениями размещаются в Области данных, которой можно придать вид табличной части отчета. Поля с повторяющимися значениями, по которым производится группировка записей, целесообразно размещать в заголовке группы.

Элементами разделов отчета, кроме поле таблиц и отчетов, на которых строится отчет, являются тексты подписей, кнопки управления, внедряемые объекты, линии, прямоугольники, и т.п. Для каждого элемента имеются соответствующие кнопки на панели элементов. Свойство каждого элемента, а также раздела и отчета в целом, могут быть, а также раздела и отчета в целом, могут быть уточнены. Технология размещения элементов и определения их свойств такая же, как и в конструкторе форм.

Упражнение 6.6.1. Создание однотабличного отчета с помощью конструктора

Рассмотрим создание однотабличного отчета на примере получения списков студентов по группам.

  1. Определим требование к макету отчета СПИСКА СТУДЕНТОВ группы.

    • Списки студентов каждой группы в отчете должны выводится последовательно вместе с заголовками.

    • Необходимо рассчитать средний проходной балл для каждой группы и отобразить его в отчете.

    • Записи списка группы должны выводится в порядке возрастания номера студента в группе.

    • На каждой странице отчета должны выводится его название.

  1. Начнем создание отчета в режиме конструктора. В окне базы данных выберем объект Отчеты и нажмем кнопку Создать.

  2. В диалоговом окне Новый отчет выберем таблицу СТУДЕНТ, которая будет источником данных для отчета. Для создания отчета в режиме конструктора выберем пункт Конструктор.

В открывшемся окне конструктора макет создаваемого отчета будет содержать разделы, указанные на рис.6.6.1.

  1. Включим раздел Заголовок отчета, если он отсутствует, с помощью команды Вид | Заголовок/примечание отчета.

  2. Для выполнение требований к группировке и сортировке данных, отображаемых в отчете, нажмем кнопку Сортировка и группировка на панели инструментов конструктора и зададим необходимые параметры в открывшемся диалоговом окне Сортировка и группировка (рис.6.6.2.).



Рис. 6.6.2. Окно определения групп записей по полю НГ и сортировки по полю НС.

  1. Зададим группировку по полю НГ, поскольку общий список должен быть разбит по группам.

  2. Выберем в окне Сортировка и группировка из списка поле номера группы НГ и зададим группировку по этому полю. Для этого в области Свойства группы в строках Заголовок группы и Примечание группы надо выбрать Да.

  3. Зададим сортировку по полю НС для вывода отсортированного списка студентов в каждой группе. Для этого в диалоговом окне выберем на ряду с полем НГ поле НС. В области Свойства группы этого поля в строках Заголовок группы и Примечание группы по умолчанию установлены значения Нет, что и определяет только сортировку по этому полю.

  4. После определения группировки в окне конструктора отчетов появляются дополнительные разделы Заголовок группы’HГ’, Примечание группы ‘НГ’.

  5. Разместим поле НГ в разделе Заголовок группы’HГ’ для того, чтобы значение номера группы было представлено один раз в заголовке группы. Для этого нажмем кнопку панели инструментов конструктора отчетов Список полей и перетащим в поле НГ в раздел заголовка НГ.

  6. Откорректируем подпись поля, изменив ее на Список студентов группы. Установим нужный шрифт в элементах.

  7. Установим размер рамки по размеру текста подписи, выполнив команду Формат | Размер | по размеру данных.

  8. Последовательно разместим поля НС, ФИО, ДАТАР, ПБалл в области данных, которая определяет содержимое строк табличной части. Поле размещается вместе с подписью которую система берет из свойств полей таблицы СТУДЕНТ(рис.6.6.3.).



Рис.6.6.3. Окно конструктора отчетов при разработке отчета для вывода данных из одной таблицы СТУДЕНТ.


Упражнение 6.6.2. Включение в отчет вычисляемого поля и добавление заголовка, текущей даты, номера страницы.

  1. Для включения в отчет расчетного реквизита Средний проходной балл группы нажмем кнопку Поле на панели инструментов и разметим элемент Свободный в разделе Примечание НГ (см. рис. 6.6.3.).

  2. Определим в свойствах элемента Свободный выражение для расчета среднего значения. Для этого запишем на вкладке Данные в строку Данные функцию =Avg ([ПБалл]), в стоку Число десятичных знаков 2, на вкладке Макет в строку Формат поляФиксированный.

  3. Отредактируем подпись поля. Для этого выделим подпись и вызовем ее свойства. В свойствах на вкладке Макет в строке Подпись запишем Средний проходной балл группы.

  4. Добавим в отчет текущую дату с помощью встроенной функции Now(). Для этого создадим в заголовке отчета свободный элемент, нажав кнопку Поле, и зададим в окне его свойств на вкладке Данные в строке Данные функцию = Now(). На вкладке Макет в строке Формат поля выберем значение Полный формат даты. Подпись этого поля выделим и удалим.

  5. Добавим в отчет номер страницы в нижний колонтитул. Создадим свободный элемент и заполним в его свойствах на вкладке Данные строку Данные выражение =[Page]. От редактируем подпись этого поля, записав Стр в его свойствах на вкладке Макет в строке Подпись.

  6. Введем название отчета СПИСОК СТУДЕНТОВ в раздел Заголовок отчета. Для этого воспользуемся кнопкой панели элементов Надпись. Установим нужный шрифт надписи с помощью кнопок панели форматирования.

  7. Для вывода названия отчета на последующих страницах введем его также в строку Верхний колонтитул. Для этого можно скопировать название из раздела Заголовок отчета, вставить в строку Верхний колонтитул и выбрать нужный шрифт. Далее надо указать Без заголовка в свойствах отчета на вкладке Макет в строку Верхний колонтитул.

  8. Перейдем из режима конструктора отчетов в режим предварительного просмотра, нажав кнопку Предварительный просмотр. Для просмотра ранее созданного отчета нужно в окне базы данных выбрать нужный отчет на вкладке Отчеты и нажать кнопку Просмотр.
1   2   3   4   5   6   7   8   9   ...   12

Похожие:

Методическое пособие по изучению microsoft iconУчебно-методическое пособие по изучению дисциплины «Менеджмент» для студентов экономических специальностей разных форм обучения
Учебно-методическое пособие предназначено для студентов экономических специальностей разных форм обучения. В данном пособии изложены...
Методическое пособие по изучению microsoft iconЛабораторная работа эффект Мёссбауэра Зеленодольск 2007 Печатается по решению учебно-методической комиссии Зеленодольского филиала кгу удк 537. 635; 537. 611. 43 Методическое пособие к лабораторным работам по атомной и ядерной физике «Эффект Мёссбауэра»
Методическое пособие предназначено для студентов третьего курса физико-математического факультета Зеленодольского филиала кгу, специализирующихся...
Методическое пособие по изучению microsoft iconМетодическое пособие выполнено п 2001 г в рамках нтп министерства образования Российской Федерации «Научное, научно-методическое, материально-техническое и информационное обеспечение системы образования»
Приходько О. Г., Моисеева Т. Ю. Дети с двигательными нарушениями: коррекционная работа на первом году жизни. Методическое пособие....
Методическое пособие по изучению microsoft iconМетодическое пособие «основы технического перевода»
Методическое пособие предназначено для помощи студентам в выполнении самостоятельной работы по переводу, реферированию и аннотированию...
Методическое пособие по изучению microsoft iconУчебно-методическое пособие по дисциплине «Страхование»
Учебно-методическое пособие составлено в соответствии с требованиями фгос впо по направлению 080100. 62 «Экономика»
Методическое пособие по изучению microsoft iconУчебно-методическое пособие
...
Методическое пособие по изучению microsoft iconУчебно-методическое пособие по дисциплине «пропедевтика внутренних болезней»
Учебно-методическое пособие предназначено для студентов 3 курса медико-профилактического факультета кгму
Методическое пособие по изучению microsoft iconМетодическое пособие для подготовки курсовых работ по дисциплине «Управления качеством»
Методическое пособие предназначено для студентов технологического факультета очной и заочной формы обучения
Методическое пособие по изучению microsoft iconМетодическое пособие по курсовой работе
Методическое пособие предназначено для студентов, обучающихся по направлению «Искусствоведение» (031500. 62), руководителей курсовых...
Методическое пособие по изучению microsoft iconМетодическое пособие по курсовой работе
Методическое пособие предназначено для студентов, обучающихся по направлению «Искусствоведение» (031500. 62), руководителей курсовых...
Разместите кнопку на своём сайте:
Библиотека


База данных защищена авторским правом ©lib2.znate.ru 2012
обратиться к администрации
Библиотека
Главная страница